Author Topic: TQVault Stopped Working  (Read 554 times)

0 Members and 1 Guest are viewing this topic.

Not Yet Rated!

Offline junky

  • New Member
  • *
  • Topic Author
  • Posts: 1
  • Country: jp
  • Karma: +0/-0
  • Gender: Male
    • View Profile
    • Awards
  • Time Zone: ?
TQVault Stopped Working
« on: 23 April 2019, 18:24:04 »
I cannot start TQVault any longer.  When I run the program I get no error message, it simply closes immediately.  I do have a tqdebug file that reads as follows:

An application error occurred.
Message : TEX magic is invalid.

Stack Trace:
   at TQVaultData.BitmapCode.LoadFromTexMemory(Byte[] data, Int32 offset, Int32 count)
   at TQVaultData.Database.LoadBitmap(String resourceId)
   at TQVaultData.Item.GetDBData()
   at TQVaultData.Item.Parse(BinaryReader reader)
   at TQVaultData.SackCollection.Parse(BinaryReader reader)
   at TQVaultData.Stash.ParseItemBlock(Int32 fileOffset, BinaryReader reader)
   at TQVaultData.Stash.ParseRawData()
   at TQVaultData.Stash.LoadFile()
   at TQVault.MainForm.LoadTransferStash()
   at TQVault.MainForm.StartLoadResources()
   at TQVault.MainForm..ctor()
   at TQVault.Program.Main()

which makes no sense to me.  If I delete the config file and enter the game location under IT or original TQ the vault will load, missing some features.  If I input the gamepath for the AE, which is the only edition I have installed (from Steam), then the program will quit before it begins and the debug log will read as such. 

Is anyone familiar with what could be going on?


Not Yet Rated!

Offline icefreeze

  • ??
  • Full Member
  • *
  • Posts: 226
  • Country: vn
  • Karma: +3/-2
  • Gender: Male
    • View Profile
    • Awards
  • Time Zone: +7
Re: TQVault Stopped Working
« Reply #1 on: 24 April 2019, 03:55:32 »
Just use another version of TQVault.
I get issue with 2.6.0 version, then i using previous version is fine.

Tags: