Author Topic: Mod Pathing Problems - Atlantis Expansion Issues [SOLVED]  (Read 111 times)

0 Members and 1 Guest are viewing this topic.

Not Yet Rated!

Offline Prosoro

  • Forum Moderator
  • Full Member
  • *
  • Topic Author
  • Posts: 221
  • Country: nz
  • Karma: +6/-0
  • Gender: Male
  • Formerly 'Nefer' of the tq.net forums.
    • View Profile
    • Awards
Hey guys  :)

There have been pathing issues encountered within certain Titan Quest mods since the Atlantis DLC happened.  Well, here's some good news!

The devs at Pieces Interactive have helped me solve this problem and I'm happy to say things are working as they should be.  So all credit to them!
 
I'll outline below what was done but first I'll just preface this by saying - these things tend to be case by case as no two mods are the same.  So depending on where you have things located etc and the nature of your modding, such things aren't always 100% the same for everyone.

As for me, the first sign of something abnormal was when building my current changes in the Art Manager.  In the build process pane an error showed up;
Spoiler for Hiden:
Then, loading up the game I found my character could not move.  Following this I also noticed no new changes were showing up ingame - I tested this by placing monsters/objects by my character spawn location and seeing if they were there ingame.  Nope.

 > At this point I'll just mention that yes I'm aware others in the modding community prior to this post have found alternate fixes - see this thread by Sauruz: https://titanquestfans.net/index.php?topic=974.msg11485#new Of course I tried these methods myself but still my problems remained.  As I've said all mods/setups differ etc etc.

I then had a thought to toggle the console while ingame and was met with a long list of errors:
Spoiler for Hiden:


The "unable to open file" from this and the "unsupported version..." from the Art Manager build step had me thinking it's something, at least in part, to do with my directory path locations.  Ultimately I was still stumped and reluctant to mess around with things incase I made it worse.  Sometime later the guys at Pieces provided some much needed insight.

The fix.
The new Atlantis DLC comes with an updated version of the MapCompiler.exe.  This is located in the Atlantis installation directory.  Therefore, the Art Manager needs to point to this new map compiler version when you are building levels/changes for your mod.  To verify this, in the Art Manager go to "Tools > Options" and ensure that the "Tools Directory" is pointing to the root directory of your Atlantis installation. (In my case, mine was still pointing to the old Immortal Throne directory, hence the aforementioned error messages)
Once this is correct, build your mod in the Art Manger and the process pane should build as normal and ingame pathing will be fixed  ;)


 
~  Anything new for TQ? See what Unearthed StudiosNZ has been up to - Details at www.hamunaptramod.com  ~


Lurking no more..

Tags: