Author Topic: Anniversary edition running inconsistently.  (Read 716 times)

0 Members and 1 Guest are viewing this topic.

Not Yet Rated!

Offline spoekels

  • Beginner
  • *
  • Topic Author
  • Posts: 6
  • Country: no
  • Karma: +0/-0
    • View Profile
    • Awards
  • Time Zone: ?
Anniversary edition running inconsistently.
« on: 27 December 2020, 12:36:34 »
I recently purchased the anniversary edition and I had a blast playing it the first session, no lag, over 200 fps average on 1440p all high graphical settings, which is not surprising given my 1080ti, ryzen 9, 32gB of ram and the game being installed on a fast SSD.

I then sat down for my next session, but the game slogs at 30fps and below, I've verified game files through steam, tried allowing the game access to more cores on cpu, run it on dx 9, reinstalled the game, updated nvidia drivers, restarting pc and starting the game freshly from boot and nothing seems to work, then randomly after leaving the pc with the game running, I come back to it going at 200 fps+ again.

I just started the game again today, and the same issue persists, I checked task manager and the game is using 83ish % of my gpu, the rest of my pc is using the remaining 17%, what do I do?

Anyone else having this insanely frustrating issue, or better yet: HAD this issue and managed to resolve it?

Any and all help would be much appreciated.

Regards

Spoekels.

Not Yet Rated!

Offline spoekels

  • Beginner
  • *
  • Topic Author
  • Posts: 6
  • Country: no
  • Karma: +0/-0
    • View Profile
    • Awards
  • Time Zone: ?
Re: Anniversary edition running inconsistently.
« Reply #1 on: 27 December 2020, 21:13:20 »
Additional information, as I've not yet found how to edit posts :)

I am not running mods, I am running windows 10, I launch the game through steam and I've now tried playing it in directx 11 and get 5fps average.

I should also say that this is the only game acting like this in my entire steam library, so this is seriously throwing me for a loop.

Regards

Spoekels.
« Last Edit: 27 December 2020, 22:12:47 by spoekels »

Not Yet Rated!

Offline MedeaFleecestealer

  • Administrator
  • Full Member
  • *
  • Posts: 1824
  • Country: ch
  • Karma: +18/-0
  • Gender: Female
    • View Profile
    • Awards
  • Time Zone: +1
Re: Anniversary edition running inconsistently.
« Reply #2 on: 27 December 2020, 22:12:49 »
Could be something in your hardware since the game hasn't changed from session to session.  Also you could try this and see if it helps.

https://forums.crateentertainment.com/t/tool-core-switcher-force-gd-to-use-all-cores-equally/100875

Not Yet Rated!

Offline spoekels

  • Beginner
  • *
  • Topic Author
  • Posts: 6
  • Country: no
  • Karma: +0/-0
    • View Profile
    • Awards
  • Time Zone: ?
Re: Anniversary edition running inconsistently.
« Reply #3 on: 27 December 2020, 22:25:13 »
Hi and thank you for trying to assist me :)

I doubt it's hardware related considering I play a lot of different games with none of the same problems, I figured out how to edit, so you might have replied before I edited my previous post, I meant to say "I should also say that this is the *only game acting like this* in my entire steam library, so this is seriously throwing me for a loop."

Nevertheless I tried the tool you provided but still get 5fps in dx11 and 30ish for (i'm guessing direct x 10 since you have to choose direct x 9) direct x 10, I am dumbfounded by this game *literally* using  95% of my cpu and 99% of my gpu :|

I snipped a picture of the process in task manager, but still trying to find my way around using this forum, and can't find how to attach a photo, so you'll have to take my word for it regarding the resource hogging :)

Regards

Spoekels.

Not Yet Rated!

Offline MedeaFleecestealer

  • Administrator
  • Full Member
  • *
  • Posts: 1824
  • Country: ch
  • Karma: +18/-0
  • Gender: Female
    • View Profile
    • Awards
  • Time Zone: +1
Re: Anniversary edition running inconsistently.
« Reply #4 on: 28 December 2020, 17:12:59 »
Well, this is the best way to do it

https://titanquestfans.net/index.php?topic=465.0

but I think the forum limits that sort of thing to you having 6 or more posts here before it can be done. 

Not Yet Rated!

Offline spoekels

  • Beginner
  • *
  • Topic Author
  • Posts: 6
  • Country: no
  • Karma: +0/-0
    • View Profile
    • Awards
  • Time Zone: ?
Re: Anniversary edition running inconsistently.
« Reply #5 on: 04 January 2021, 11:45:09 »
Welp, my motherboard died shortly after making this thread, so when my new one arrives I'll give you an update as to whether or not the motherboard was at fault, but it seems likely.

Not Yet Rated!

Offline UrQuan101

  • Visitor
  • *
  • Posts: 4
  • Country: za
  • Karma: +0/-0
  • Gender: Male
    • View Profile
    • Awards
  • Time Zone: +2
Re: Anniversary edition running inconsistently.
« Reply #6 on: 06 January 2021, 10:24:49 »
I hope you get it sorted out.

I had problems with framerate dipping, but got it solved by moving installation to SSD and enabling VSync on 144Hz. I may also have disabled GSync. I'm not entirely sure what corrected the issue, but I now have smooth gameplay.

Good luck.

Not Yet Rated!

Offline spoekels

  • Beginner
  • *
  • Topic Author
  • Posts: 6
  • Country: no
  • Karma: +0/-0
    • View Profile
    • Awards
  • Time Zone: ?
Re: Anniversary edition running inconsistently.
« Reply #7 on: 21 January 2021, 16:01:53 »
Got the new motherboard and it is acting exactly the same, I guess this is just one of those games I'm not meant to play, it's limited how much effort a man can put into being able to play a game  >:(

@UrQuan101
This is more than dipping, it ran at 3-5fps average last I checked, I've tried v/gsync fiddling, and it's installed on very quick samsung nvme disks, thanks though :)
« Last Edit: 21 January 2021, 16:03:37 by spoekels »

Not Yet Rated!

Offline Ninakoru

  • Beginner
  • *
  • Posts: 9
  • Country: es
  • Karma: +0/-0
  • Gender: Male
    • View Profile
    • Awards
  • Time Zone: +1
Re: Anniversary edition running inconsistently.
« Reply #8 on: 01 February 2021, 20:04:11 »
You tried downgrading to Direct X9?

Not Yet Rated!

Offline spoekels

  • Beginner
  • *
  • Topic Author
  • Posts: 6
  • Country: no
  • Karma: +0/-0
    • View Profile
    • Awards
  • Time Zone: ?
Re: Anniversary edition running inconsistently.
« Reply #9 on: 05 February 2021, 13:33:12 »
@Ninakoru
As stated in my original post, yes:) DX9 and 11 had different fps, but not by much, averaged 8-10 on dx 9.

Tags:
 


SimplePortal 2.3.7 © 2008-2021, SimplePortal