Titan Quest - Anniversary Edition > Technical Support

PS Editor (Effects Editor)

<< < (4/4)

nobody got a fix to this? i was able to use the PSEditor last week. loading a pfx does nothing anymore. super frustrated.

Here is my way how to make PSEditor work with Atlantis:

1. Magic mod name "Art_TQA2" is default mod name hardcoded in PSEditor. In Atlantis this mod name defaults to "Art_TQX3". You can change this mod name in Tools.ini in Editor section with lastMod option (don't mix up with other sections which may hold own option with same name). E.g.

--- Code: ---[Editor]

--- End code ---

In this case PSEditor will look for .pfx in ...\Working\MyMod\source directory.

2. Now you need give access to resources. PSEditor looks like scan game archives, but for me, for some reason it doesn't read them from game archives. However, it looks resources in the folder derived from Tools.ini file, Login section, additionalbuilddirs option. So if you specify this option - it will look-up resources under {additionalbuilddirs}\Database (e.g. if you specify C:\MyDir it will look them in C:\MyDir\Database). When this option is not specified, it look-up resources under Titan Quest - Immortal Throne\Database. So in this folder you need typical resources structure, e.g. Shaders and Effects folder(s).

As side note: There is exist PSEditor.cfg file, however what is configurable is unknown.

PS: If you a familiar with filesystem directory junctions (symbolic links) then it might be easier to extract Effects.arc into some mod directory (into source folder), and then make "Database" directory alias somewhere where it might be pointed by Tools.ini.

After having to revert my graphics drivers because the latest AMD drivers refused to see my second monitor, the original THQ PSEditor stopped working, just errored and quit.

So I went back to the Steam version and, although the application loads up okay, nothing in the editor worked. I discovered what directory it was HARD CODED TO LOAD AND SAVE FROM (really?? a file picker in Windows is so easy to implement, this is outrageous. If I had made this I would have been fired).

So @lixiss used the word "permission". And I thought "permissions"? So I "ran as administrator" and the Steam version actually worked! WTF?? I have to run PSEditor as administrator? WHY??

So I could work with and see the emitters and grid lines, great. The background color no longer saves to the pseditor.cfg file like with the original THQ version, guess that was also too much trouble to port over to the new versions. Oh well.

Anyway, I wanted to post this in case someone ends up from a google search in the future. Along with the other helpful tips in this thread, try running PSEditor as administrator and see if that does the trick.


[0] Message Index

[*] Previous page

Go to full version