Titan Quest - Anniversary Edition > Technical Support

Anniversary edition running inconsistently.

<< < (2/2)

Welp, my motherboard died shortly after making this thread, so when my new one arrives I'll give you an update as to whether or not the motherboard was at fault, but it seems likely.

I hope you get it sorted out.

I had problems with framerate dipping, but got it solved by moving installation to SSD and enabling VSync on 144Hz. I may also have disabled GSync. I'm not entirely sure what corrected the issue, but I now have smooth gameplay.

Good luck.

Got the new motherboard and it is acting exactly the same, I guess this is just one of those games I'm not meant to play, it's limited how much effort a man can put into being able to play a game  >:(

This is more than dipping, it ran at 3-5fps average last I checked, I've tried v/gsync fiddling, and it's installed on very quick samsung nvme disks, thanks though :)

You tried downgrading to Direct X9?

As stated in my original post, yes:) DX9 and 11 had different fps, but not by much, averaged 8-10 on dx 9.


[0] Message Index

[*] Previous page

Go to full version