Titan Quest - Anniversary Edition > Technical Support

[HOWTO] TQ:AE + WINE = No sound?

(1/2) > >>

Hey everybody,
just did some updates yesterday, including an update to wine 5.12, and all of a sudden the sound in the game stopped.

It was possible to turn it on in the game options but as soon as it tried to save, it stopped working again.

I tried a couple of things and this is how I solved it YMMV:

1) Open the "options.txt" file in a folder like:
$WINEPREFIX/drive_c/users/$USER/Meine\ Dokumente/My\ Games/Titan\ Quest\ -\ Immortal\ Throne/Settings/

Replace "Meine\ Dokumente" with a path like "My\ Documents" depending on your profile language, of course. :)

2) Set the values to either "0" (off) or "1" (on), values like "0.4" did not work, eg
masterVolume              = 1
musicVolume               = 1
effectsVolume              = 1
dialogVolume               = 0
inputVolume                 = 0

3) Enjoy the game again with sound!

Have a good time, hope this helps somebody...

Cool, this could be from help to someone. Wine is for Linux players?

Medea Fleecestealer:
Yes, Wine is for Linux users.

telsh, have you tried using Steam's Proton for playing the game using Linux?


--- Quote from: MedeaFleecestealer on 25 July 2020, 08:42:05 ---telsh, have you tried using Steam's Proton for playing the game using Linux?

--- End quote ---

Hey Medea!
No, not yet, right now the game I play (mostly (A)RPGs) run either native under GNU/Linux or ok-ish with wine (like TQ)
This might change, of course, and then I'll give it a try, especially as Non-Steam games can be run with it now.
The latter is pretty important for me as almost all of my games are from GOG. I just love to be able to use the offline installer! :D

Do you have some experience with Proton?

Medea Fleecestealer:
No, not at all.  I only know of Proton via some Steam GD forum threads about problems running that game on Linux.  It seems to run pretty well with Proton now.


[0] Message Index

[#] Next page

Go to full version